Resolved
We've identified and fixed the cause of new user registration failures on BSN.cloud. The issue was due to a problem with an authentication server component related to the user registration flow.
Identified
We have identified the new user registration issue and we are now rolling out a fix to address the problem.
Investigating
BSN.cloud new user registration is currently unavailable. We are currently investigating the problem.