Resolved
Our engineers have now resolved the issue and file uploading is now working.
Identified
File uploads to BSN.Cloud are currently unavailable following today's platform updates. Engineering is actively investigating and working toward resolution.